Adds support to SilverStripe for embedding Vidyard videos easily into your SilverStripe powered website.


Repository: https://github.com/webbuilders-group/silverstripe-vidyard-embed

Packagist: http://packagist.org/packages/webbuilders-group/silverstripe-vidyard-embed

Issues: https://github.com/webbuilders-group/silverstripe-vidyard-embed/issues

Authors: Ed Chipman

1 1 372


Readme

Vidyard Embed

Adds support to SilverStripe for embedding Vidyard videos easily into your SilverStripe powered website.

Maintainer Contact

Requirements

  • SilverStripe Framework 3.1+

Installation

Composer (recommended):

composer require webbuilders-group/silverstripe-vidyard-embed

If you prefer you may also install manually:

Usage

This module provides a new insert media option called "From Vidyard" which functions very similar to the "From Web" however it is specific to Vidyard which does not at this time support oEmbed. The link expected in this field is either the "Sharing Page" or some of the settings pages including the embed select page (for details see the documentation). You will need an API Key from Vidyard as it is used to lookup the information to embed see here for information on where to get this. Once you get your api key from Vidyard the user key will suffice. You must add the below to your config before you can add Vidyard videos using this module.

Vidyard:
    api_key: "YOUR_API_KEY_HERE" #Vidyard API Key

If you want you may also add this short code manually to your WYSIWYG by using the below syntax, all arguments are optional.

[vidyard,width="600",height="480",class="leftAlone",thumbnail="URL_FOR_THUMBNAIL"]URL_FOR_VIDEO[/vidyard]

Versions

dev-master
2017-03-14 3:03pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed dev-master

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.4.1
2017-03-14 3:00pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.4.1

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.4.0
2017-03-14 2:53pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.4.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.3.0
2016-11-24 9:02pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.3.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.2.3
2016-06-16 8:38pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.2.3

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.2.2
2016-06-08 6:50pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.2.2

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.2.1
2016-03-07 3:14pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.2.1

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.2.0
2016-03-07 2:57pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.2.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.1.1
2016-02-05 7:46pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.1.1

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
0.1.0
2015-12-11 7:15pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-vidyard-embed 0.1.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1