Wraps gridfield adding support for using it on the front-end.


Repository: https://github.com/webbuilders-group/silverstripe-frontendgridfield

Packagist: http://packagist.org/packages/webbuilders-group/silverstripe-frontendgridfield

Issues: https://github.com/webbuilders-group/silverstripe-frontendgridfield/issues

Authors: Ed Chipman

16 8 6.6K


Readme

Front-End GridField

Wraps gridfield adding support for using it on the front-end of a site.

Maintainer Contact

Requirements

  • SilverStripe Framework 3.1.x+

Installation

Usage

Instead of using the GridField class you need to use FrontEndGridField for use on the front-end, note it is not recommended to be used in the CMS. As well instead of using the GridFieldConfig extensions provided with SilverStripe use FrontEndGridFieldConfig_Base, FrontEndGridFieldConfig_RecordEditor, FrontEndGridFieldConfig_RecordViewer, or FrontEndGridFieldConfig_RelationEditor. If you are building your own GridField config ensure that you use FrontEndGridFieldDetailForm instead of GridFieldDetailForm.


Versions

dev-master
2017-03-31 1:04pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield dev-master

Manual Install: Download

Requires
  • composer/installers: *
  • silverstripe/framework: ~3.1
0.4.0
2017-03-31 1:04pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield 0.4.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
  • composer/installers: *
0.3.0
2017-03-21 1:37pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield 0.3.0

Manual Install: Download

Requires
  • silverstripe/framework: ~3.1
  • composer/installers: *
0.2.0
2014-12-13 6:36pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield 0.2.0

Manual Install: Download

Requires
  • silverstripe/framework: 3.1.*
  • composer/installers: *
0.1.1
2014-01-03 3:50pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield 0.1.1

Manual Install: Download

Requires
  • silverstripe/framework: 3.1.*
  • composer/installers: *
0.1
2013-12-11 8:29pm UTC
BSD-3-Clause

Install composer require webbuilders-group/silverstripe-frontendgridfield 0.1

Manual Install: Download

Requires
  • silverstripe/framework: 3.1.*
  • composer/installers: *